Increased App Latency & Request Failures
Affected components
App
Updates

Write-up published

Read it here

Resolved

This incident has been resolved.

Thu, Oct 30, 2025, 12:36 AM

Investigating

We are currently investigating this incident. More details as the event progresses.

Thu, Oct 30, 2025, 12:20 AM(15 minutes earlier)
Powered by